Z safe travel first

I know there is an easy solution to this. I am starting (home) the tool on the table 100 mm X negative to my stock. I would like it to lift to my safe height first, then travel to over the stock.
Using foam as I always mess up a few times. At present the tool stays at table height and runs sideways into the stock.

Thanks all.

does output -> first Z max solve this for you?

Screenshot 2024-05-19 at 4.24.16 PM

I will give it a try. thankyou.

I knew there would be something easy and obvious in there!
Worked like a charm.

I have no end of questions!
This is practice for the creation of an airfoil leading edge. I am not certain that the KMZ I included is accurate anymore as I have messed with it endlessly. The photos show how the machine runs a rounded corner racetrack pattern even though the part is square.
Any clues what I have buggered up?
leading edge with lip.kmz (287.6 KB) This should be flip not lip!


whenever you have a situation like this, it’s helpful to include the exported workspace (right click then export) as a .kmz – from there I can exactly replicate your issue

Sorry Stewart, thought I had that in there.
leading edge with lip.kmz (287.6 KB)
I have messed with this so much that it may not be the actual version I cut. When I cut it I sliced and exported- cut each procedure separately.

You did have it in there, but I missed it! My bad.

The gcode output and animations do not show those curves. When you import the KM gcode into your controller does it show something different from what KM shows in preview?

Very strange! I did the files over again, animation in KM is perfect. Took the files to the shop, index holes cut perfectly. Next he cut file comes up on the screen, looks perfect… then the actual cut is a racetrack!
I have a friend that also uses Linuxcnc, May be something in there.
I am going to put today’s file in here as well. Oddly the tabs did not show up on the cnc today, they did cut last time. I stopped long before I got to that depth today.
workspace.kmz (4.3 KB)

if the cuts don’t match the gcode render, then I’m not sure what’s going on … unless travel moves that intersect material (which would be a bug) are not being rendered. please re-attach the workspace with the parts included. I can’t apply these settings to the old part and retain things like tabs.

Sorry Stewart, I don’t know enough to understand what you are asking. “workspace with the parts included” I think understand the workspace part, portion visible on the screen. Do you need the original stl file? Will not allow stl, I will convert it if you need.
The bit does make odd cuts in the corners that will mill roughly 8mm worth of depth through previously unmilled foam. Different than the racetrack, actually the deep cuts happen after the racetrack when the corners get squared up during the contour process.

either right click “export workspace” or export profile and check “include workspace” … both will produce .kmz files with all the parts and settings in the current workspace. from there I can reproduce any problem that originates in KM.

the mill should not cut any paths that are not rendered. so I’m not sure what’s going on.

racetrack1.kmz (267.8 KB)

Think I got it.

I don’t see anything in the generated gcode that would cause that “racetrack”

Looks perfect when in comes into Linuxcnc as well. Friend of mine is good with Linux, I will see what he comes up with. I will let you know what he finds.

He thought I might have a G64 P value too high. I could not find a G64 anywhere.
I am going to try upgrade linux to latest version.

In my coutour I have precision entered as one. I really have no idea what this does, anything to do with rounding the corners? I created a different drawing and tried to cut that same result though.

maybe? you should leave it at 0 and update display → animation preference to 1000, 2000 or more and let it be auto-calculated. either way, the gcode preview should be accurate.

I should only change one thing at a time. Contour was not the issue it was the first process, Rough, so I threw the G64 p0.1 in using the Machine and header. Have square corners. I need to learn something about Gcode.

thankyou Stewart.

Make sense. It’s a firmware setting that rounds corners. I would not expect such an aggressive default in the firmware.