Outlines and contours disagree on part shape

I’m using 2.3D9, but this has been happening with all of the 2.3Dx releases, I believe. Outlining and contouring have a fundamental disagreement on the limits of my part.

In addition, it seems tabs might be ignored by the contouring pass. That doesn’t show in the above image, because the contours aren’t going to the edges of the part for some reason. (I think they did, in a previous Dx release, and it was clear that the contour cuts were going to cut away the tabs left by the outline pass.)

I spent a lot of time on this yesterday, as it happens. Is inside only checked in contouring? Tabs should work in contouring. There is only one bug left there that I know of and will fix today.

Yes, “inside only” was checked. I’ve now unchecked it. The countours now look more reasonable but the outline still goes straight across the arms of the ‘U’.


whatever it is, i’ll fix it for tonight’s release

I am attempting, but failing, to replicate this problem. Mind sharing model and settings?

Sure – how do I do that? I’m using Onshape.

@pgf to share your settings, select profile -> export (pictured) to produce a .b64 file … to share the model, either use Onshape’s existing share function or just export the STL. then email me (sa@grid.space) the .b64 file … and the STL if you don’t use Onshape’s sharing. Alternatively, you can drop that stuff to me in chat on Discord.

Screen Shot 2020-11-15 at 4.20.44 PM

@pgf Another aha. I looked at your first picture, and I think you meant roughing instead of outlining. There is a problem with roughing with this model, but not with outlining. That fix will be pushed tonight.

Thanks for the bug report. I would have missed this.

I’m a little confused about what you saw and what you fixed, but to be clear: I have roughing disabled.

that’s equally confusing then. I don’t see how to produce the first picture with outlining enabled. I was unable to with the model and settings you shared, either.

it’s possible I’ve fixed this in D10 and thus can’t replicate it anymore.

But you agree that the settings I sent you have roughing disabled and outlining enabled, right?

Yes, this appears to be the case. However, I have also discovered a bug in the settings import process that incorrectly re-enables some things. Like roughing. :exploding_head: So I’ll be reviewing that again.

D10 just posted, so please let me know if this problem persists.

The problem persists.

truly stumped. I’m working with your part and your settings and I’m getting results that are as I expected (similar to pics I posted above). perhaps there is something environmental or improperly cached. I would really like to replicate and fix this.

can you try this in a private browsing session? that should eliminate most or all variables like that.

If I try private browsing, I get a “local storage blocked, application may not function” error, and then the Kiri tab, in Onshape, hangs.

So I tried in Firefox, and I get the same results I was getting in Chrome. :-/

I tried importing the STL I sent you into FF, and I can’t seem to get anything but your default cube-with-cutouts object. I must be doing something wrong.

My laptop is almost out of juice, so can’t continue right now.


I spent a lot of time pouring over the profile export / import code and found a few holes. I’ve patched those up and added the option (see checkbox) to include the workspace objects (positions, scale, etc) in the export. This increases file size substantially (when enabled), but allows you to perfectly capture (and share) a snapshot of your workspace, settings, and objects.

This will go out with 2.3.D11 this evening. Hopefully we can try this again with new export code.

1 Like

That sounds good. I confess I had trouble actually getting my part loaded into the kiri tab. Usually there’s an open pane on the left called “Select part or assembly” that I use when starting. But today that pane was usually missing, and I couldn’t figure out how to bring it up. On FF, it was missing in the first kiri tab I brought up, but then was present when I brought up a second kiri tab. I’m sure there’s a way to force that “Select part or assembly” pane to appear – I just couldn’t find it.

There was a brief problem with a cache of old code being served shortly after I pushed the update. It could have caused Onshape problems. If you see something like that, you could try opening the Javascript console and looking for errors (like 404 file load problems)

I’ve cleared all cache and cookies in Chrome. Problem persists.
I’ll wait for 2.3.D11, and get you a new copy of my stuff. I guess if I understood the Onshape sharing configuration dialog, I could share the part directly through Onshape. If you made a copy of the project, could debug from that?