Laser mode no color for merged slicing

In the Laser mode, under Output, the tool tip next to Merged says that layers will be color coded to denote stacking depth. But when I run Slice or Preview, I see only black. Is that feature not enabled yet, or am I just doing it wrong?

Newbie to KM

Hi @jsteward and welcome! If it’s not working like the YouTube video, then it’s possible I broke something recently. I will investigate this afternoon and let you know. If you can share the STL you’re using in the meantime, that would be helpful.

So, I checked this with the models I use and it’s working as designed. However, this may not be what you are expecting. Once you share your STL I can get a better sense of what’s going on.

I looked through the youtube videos and never saw it demonstrated. Can you provide a link?
Here is a file that it doesn’t seem to be working on:
Based on your next comment, I must be doing something wrong. My expectation was that in the merged mode, I would see all layers at once, piled on top of one another, and each layer would be a different color. Right now they are all black. And when I export as an SVG and open in Inkscape, they are still all black. Trying to figure out which layer comes next to stack up is often tricky, so the color coding would be very useful. Thanks.

Well I found the Youtube video. Looks neat, wish it worked for me. I have tried it on MS Edge browser, Safari on iPhone, and Chrome. I get the same result, just a stack of black lines. I’ve tried the default cube model and lots of other things. I must be doing something wrong. Thanks for any help and guidance.

I made a video this morning to show how it’s supposed to work. Let me know if this helps clarify.

I’ve just been looking at Kiri for laser output, as well as using it for CNC operations, which it’s done brilliantly at. Thank you for making it available!

In my use-case, I’ve got some topographic data, which I’d like to slice up to laser out the layers. I end up with about 38 layers, using 1mm slices. I can output SVG or DXF, which I can get into the laser cutter without issues, but it’s all black and separating the 38 layers by hand is near impossible.

What I’d love would be a mode where each layer it slices gets assigned a different colour value (or layer, in the case of SVG/DXF). That way, everything is aligned and I can enable/disable the layers, in order to cut the sheets one by one.

Here’s the model I’m slicing:

@Barnaby_Relph welcome and thanks for the feedback. I will add an output option to uniquely color code each layer. In the meantime, if you look at the SVG output, you will note that each svg polyline is annotated with a z index value.

@stewart Thanks, that’d be amazing! I’ll take a look at the SVG files in the meantime.

I’lll post a pic here when I get something made.

@Barnaby_Relph pushed to production (layer color)

laser colored layers

@stewart Thanks for putting that up so very fast!

I’ve been for a look and unfortunately, I can’t reproduce the coloured view above. I’ve tried both Chrome and Safari and whilst I get the new “layer colour” option, the resultant output is single-colour.

I’ve tried using the default object, as in your screenshot and I also get a single-colour view. I’m not sure if it’s something I’m doing?



@Barnaby_Relph can you try shift+reload on the kiri:moto page? perhaps the code is stale in your browser.

Hiya, I’ve given reloading a go, as well as pulling the code and running it locally (which I have to say was an absolute breeze!)

Unfortunately I’m not able to reproduce the screenshot above with coloured layers, which is very odd. I’ve played with a few options, but can’t seem to reproduce it. I’m not quite sure how to proceed, but thanks very much for putting the feature in, I’ll try reading the commit next and see if I can work out what’s going on.



@Barnaby_Relph I re-tested on and it’s definitely working. Can you attach screen-shots of your slicing and output options? If you hover over the Kiri:Moto title or open the help menu, what version shows up?

@stewart Thanks for getting back to me! I’ve been for another look and I’ve worked out a few things. I couldn’t get the layers to show as coloured in Kiri itself, but looking at the generated SVG, I can indeed see colours!

They also show up nicely and automatically become different layers in LightBurn, which I use to run my laser:

What I have noticed though, is that when I select “merged” to line all the slices on top of each other, the colour becomes white for all layers. Opening the file in Inkscape initially I thought there was nothing there, until I looked at file size, but reading the raw file showed me there’s data there.

I’m still looking at the code, but I’m guessing when ‘merged’ is selected, something about the height data could be getting removed before the height->colour code kicks in?

Thanks very much fo looking/working on this, it’s really appreciated!

merging is not a feature for terrain maps. it’s more for signage and other more geometric patterns where you want to use some outlines for cutting and others for etching, but they intersect or overlap. i would only recommend it be used with a model that you have CAD control over.

what were you hoping to achieve with merging?

Hi Stuart, thanks for getting back to me. My use-case is that I want to cut layers to build up topography in 3d. In particular though, my plan is to use the scrap to help align each layer on the underlying layers as I assemble. Whilst I can get each layer out nicely as a separate entity, re-arranging them as overlapping layers, so I get consistent alignment is where I’m trying to go.

This is what I managed to get using the test shape, but I think that was whilst playing with the code locally and flipping the zColor flags. I’ll have a bit more of a play.

Did you have any luck getting merged data out? I cannot make the software do this. I too am trying it with terrain. The “preview” and “export” buttons don’t do anything when I have the model selected.

I can import a terrain model. I can slice the model. I can “preview” and “export” the model, colored and all laid out. However, if I select ‘merged’ as an option, the “preview” shows the same as the sliced, sort of a 3d view of things. And export does nothing.

Looks like I can get it to work in 2.3 and 2.2, but not 2.4 or 2.5. Also, the algorithm is automatically closing the last two endpoints.