Z depth incorrect

I was testing out hole sizes to make an MFT-style grid on my MDF spoilboard to find a good fit for my bench dogs. So I created a part in Onshape with five holes and extruded it to 19.45mm - the exact thickness of the MDF I’m using. Next I set up a roughing cut in Kirimoto, followed by a finishing (outline) cut. I have the following settings in Kirimoto:
Stock Tab: W/D/H = 0, offset is checked
Limits Tab: Z offset, bottom, and through all set to 0

After I removed the test piece of 19.45mm MDF I saw ~1mm pockets cut into my spoilboard. So I looked at the gcode, and I see that all the cuts go to a final depth of Z-19.99.

Why does the gcode exceed Z-19.45mm if Z through is set to 0? With the given settings I would have expected a 19.45mm deep pocket, with either a slight mark on the spoilboard, and/or a paper-thin bit of MDF left at the bottom of the holes.

Note, I’m not worried about the spoilboard - that’s its purpose, I simply want to understand why I’m getting the results I am. It’s the curse of being an engineer; I always need to know the how and why of things and what I may be doing wrong or misunderstanding :wink:


Z-depth_issue.kmz (489.2 KB)

I imported this workspace into several versions if KM and could not get it to reproduce this error. All final Z cut depths were 19.45mm from top of part.