Toolpathing process seems to be stalled…?

I have recently been experiencing this problem - The toolpathing process seems to be stalled…?
Is this a RAM memory problem? Thanks for any advice you may have on this issue.
Also I cannot reinstall my workspace preferences from my local drive. All my tool preferences are gone after clearing cookies to try to resolve this problem. How can I load my tool preferences back in?

did you save your workspace or export your profile at any point? can you right-click export that workspace and share it with me so I can reproduce the problem?


Thanks for your quick response.
Unfortunately I lost the workspace for this particular issue, I cleared the cache of my browser tin an attempt to clear any memory issues that might be contributing to this problem.
In the process I cleared my profile preferences. Any way to restore them without manually entering my tool prefs?

your settings are all stored locally in the browser. so if you clear the cache, your settings are gone. unless you export them and save a copy.

Yes I did. However I cant find a way to load them from my local drive, they are contained in a .KMZ file (I think)

oh. just “import” a .kmz like any other file or drag/drop a .kmz file onto the workspace

Oh thanks! I had no idea it would be so easy! :smiley:
(…and the cache clear took care of whatever problem was causing the original issue for the posting of this thread)

1 Like

Hm, its back. Stalled toolpath processing.
Ive tried twice to save workspaces, both times it appears to have failed… I gave it time to work, a while later looked for it to link here but its not on the drive.

Do you have any recommendations regarding performance optimizations, perhaps which browser is best running Kiri:Moto, memory configurations, or browser settings for it?
It might not be Kiri:Moto at all, Im having problems processing high rez meshes at twice my usual physical sizes, in higher resolutions too. But after half an hour, the process seems to stall at about 1/3 into the full process, still displaying ‘shadow’. Is it possible to take the computer off the internet during a long process (at least until it has to be downloaded)? Alternatively, can you point me to resources I might find to learn how to install your excellent software locally?
Thank you for your help.

whether the KM server runs locally or on the internet makes no difference to processing because that happens in the browser on your computer. nothing happens on the server. running a local server is only useful if you want to develop the KM code base.

all of my computers have at least 8GB or RAM. that usually allows Chrome or Edge to use up to 3.2GB for processing. less memory and you may have issues with complex models.

Thanks for those tips.
Tested processing offline, which works best for me by previewing then going online before downloading. However, the larger files choke at about 1/3 of the way, before topo slicing stage.
Im using Firefox currently, perhaps I should try Edge?

In Kiri:Moto, there is no difference between “online” and “offline”. So I’m not sure what you’re referring to. Kiri:Moto does all processing in your local browser. Even the export / download is generated by the code running in the browser page.

Please share your workspace so I can review the model and settings. Topo slicing is very memory and compute intensive depending on the settings you’re using.

Roughing process has been stalled for hours. I gave up waiting after 2 hours.
Weird thing though - KiriMoto processed the finishing pass, but not the roughing.
I tried to save the workspace, (multiple times, including prior to your last request for one in this thread) it will not save!

Workspace finally saved, sorry here it is
AgeOfLoveWrkSpceFAIL.kmz (15 Bytes)

Unfortunately, the export failed.

Maybe this works?
I tried uploading here, it kept failing to upload

Tried processing the same file in Edge, which eventually failed, stating an out of memory error.
Odd… I have a new laptop, gaming gpu, with 8 gigs of ram, but it appears that I dont have enough ram to process this file.

Got it this time. It’s a very complex model. I’ll see if there’s something I can do to reduce memory consumption during pre-processing. CNC work I’m already doing for 3.4 should help with this.

@bongo_matteo In the meantime, I was able to complete path routing by enabling skip shadow. This is currently more processor and memory intensive than it needs to be. And I’m working on improvements.

Screen Shot 2022-05-01 at 12.08.45 PM

Thanks SO much for your help. I will try it again within a day or two.
Your tech support is truly superb.

I tried it just now, what a difference! Great work.

1 Like