Tool chuck interferes with stock for deep cuts?

Trying to cut a large hydrofoil on a 52x52" cnc router with 8" depth axis. The toolpath would cause my chuck/spindle to interfere with remaining stock. I want to cut entire layer of stock before stepping down to next layer of rough cut. Rough cut operation only removes stock with profile of part causing a deep hole which interferes with chuck. Foil is about 4" in z but cutter is only about 1.5" so chuck must go below top of stock. 2021-05-29T07:00:00Z

Hello j_keiter,

I am not Stewart, but I’ll take the liberty of saying: Welcome to grid.space!

Do you have ‘depth first’ selected under ‘output’? If so, try clearing that to rough by entire layers.

Was unchecked. I previewed a rough cut operation with checked and unchecked. Still makes a hole that causes interference with chuck on deep areas. You mentioned “rough by entire layers”. That sound like what I need. I have not see an image or video of kirimoto clearing a full layer of stock around the part then stepping down and repeating. Thx Jason

I haven’t fully explored the latest KM development, so I’m really just making this up:

It looks like KM isn’t understanding the continuous shape of your foil tween slices.

You have a two sided part with the “sides” split by a curved surface. I’m guessing you would want to rough down to that surface. And leave some tabs around the foil on that surface. Then flip it over and do the same for the other side. (maybe after further surfacing ops on the first side) I don’t think KM will figure that out automagically.

To flip & index the workpiece you will probably want some full-thickness material left around at least the corners if not the full perimeter. That will require the deep ends of the roughed area to slope/step back up to the top face. Unless you plan to flip it into a negative jig. I don’t think KM will figure that either.

I think I’d model completely what I want cut: a pocket around half of the foil rising from the curved surface that splits it top from bottom, with some (halves of) tabs around the foil edge on that surface, and with the outside wall of the deep ends of the pocket relieved to clear the chuck. Then give that to KM as a pocket. With index pins. Then model the pocket from the other side down to other side of the same surface, leaving the other halves of the tabs.

Hopefully Stewart will say if I’ve just made a hard way to do an easy thing.

Appreciate your thoughtful solution. I don’t know if I have it in me to do this in Blender. I’m a noob and repairing mesh has been a pain.

welcome. I was away all of yesterday and unable to respond. if the part is not slicing properly or generating a colliding tool path, would you mind sharing the STL with me? sa@grid.space – I’ll see if this is, indeed, a bug. and if the part is non-manifold, will check if it’s easily healed. from the slice lines posted, it does appear to be a likely scenario.

1 Like

I am seeing the same scalloping of the edges with larger step-downs. the holes in the middle are milled out because they are smaller than the endmill size selected. unlike the outline operation. roughing does not (currently) allow you to omit through holes. so I will look at adding this option to roughing.

decreasing the step-down improves, but does not eliminate the scallops.

outline paths are less affected.

this appears to be a bug with the “shadow” generator. so I will use this model to debug that.

after digging into this more, I understand the source of the scalloping. it’s not really a bug in that code is working as designed. however, it does not handle thin, non-planar edges gracefully. so I’m going to have to design a better method for parts like this.

My main issue is the preview/animation would cause my tool chuck to interfere with remaining stock near the tips of the foil due to the depth. I’m guessing you understand my issue and I don’t understand your solution. I’ll keep an eye out for updates and continue trying to learn all the options. I REALLY appreciate your work. Wish I could code like you.

Jason in Vacaville

added true shadow option in 3.0 dev – see if that helps

Screen Shot 2021-05-31 at 5.11.45 PM

I tried both Skip and True Shadow. At the tips of the hydrofoil it still appears the tool will cut deep into stock such that chuck will interfere with stock. Is there a way for me to mill the entire piece of stock layer by layer such that there will be no stock left to interfere with chuck?

Thx again Jason

You’re right. There is another bug with the shadow generation. Will look into it again tomorrow.

OK, I have a much better fix for this now. Will be pushing an update in a few hours.

@j_keiter 3.0.D2 should fix the shadow generation with true shadow set

preventing paths that exceed the cutting edge depth is on my todo list

1 Like