Skips last cut & TypeError

Issue 1:
I’m probably doing something wrong but it seems most of my exports always skip the last cut.
workspace (1).kmz (3.8 KB)
Letters_1.gcode (12.7 KB)

For example on the attached gcode I’m cutting out 3 letter A’s. I do 3 passes, doing down 2mm each time. But the last pass of the last cut on the A wasn’t done. So it was fully cut out except one side still had 2mm left.

It also happens if I cut with thinner material and have it cut though all at once.

However it doesn’t always happen?

Issue 2:
When trying to export I keep getting:
image
If I delete everything and re insert it sometimes works.

probably a 3.0 bug? I’ll look into this shortly. thanks for the report.

They were both happening on 2.9 for me as well.

ok, then good to have a workspace I can debug with. will let you know what I find.

do you mind right-click exporting workspace or exporting profile and checking include workspace? without the parts, it’s hard to replicate. the gcode you posted does three step down cuts on each letter. it does not appear to be missing anything. was that meant to be an example of a defect? is it possible it’s something in your gcode sender?

Here is a workspace export for the ‘reading round’ error. I even switched versions all the way back to 2.6 and it still wouldn’t export. Tried doing one model at a time as well. Chrome Version 95.0.4638.69. round_error.kmz (488.1 KB)

I would assume it also would skip the last cut, unfortunately I’ve already cleared my workspace for the gcode I posted.

I’m using it on a lowrider CNC running marlin using an SD card. I’m not sure how to troubleshoot if it is the issue but I also haven’t changed anything on it for months.

thanks for the workspace. found and fixed the export error. will be in tonight’s update.

1 Like

if you enable stock in offset mode with 0,0,0 offsets it will work around the bug

Thanks for fixing the export error!
Here are some more things to maybe figure out the last cut, if it’s even Kiri.

I just did a cut where it does it all in one pass and so the last cut was still skipped. However I have an older gcode that I exported probably in like version 2.1 that I use a lot and it always cuts everything. Maybe its possible to see what is different?

no_last_cut.kmz (256.9 KB)
no_last_cut.gcode (4.3 KB)
old_gcode_that_works_perfectly.gcode (94.9 KB)

the difference between the two files is that one contains comments (new one) and other one doesn’t. I’m guessing that if you re-enable strip comments in the device profile, it will resolve your troubles. The low-rider profile in your workspace has this turned off. Marlin style comments probably confuse some GRBL senders.