Rotary 4th axis STL rough & lathe question

HI, I am trying to mill an stl on a Carvera 4th axis.

Is the following the correct order of operations & should the index 0 be placed before Lathe?

Index - 0 degrees absolute
Index - 180 degrees absolute
Index - 0 degrees absolute

I am using an endmill for rough & v-bit for Lathe.

The roughing operations seemed to work as expected, but I have paused the job at the start of the Lathe operation because it doesn’t seem to be following the cuts from the roughing operations.


It’s been a while since I ran a job like this. But my memory of it was that I separated roughing and lathe ops into separate gcode files because the Carvera controller was not honoring A axis index resets. But, in theory, your setup is what I would expect to work.

1 Like

The gcode produced by the lathe toolpath is doing something strange, here is an example:

G1 Z3.5689 A350.0000
G1 Z3.5570 A351.0000
G1 Z3.5367 A353.0000
G1 Z3.5282 A354.0000
G1 Z3.5000 A-360.0
G1 X3.1398 F1100
G1 Z3.5282 A-354.0 F1000
G1 Z3.5367 A-353.0
G1 Z3.5570 A-351.0
G1 Z3.5689 A-350.0

Notice these two lines:
G1 Z3.5282 A354.0000
G1 Z3.5000 A-360.0

The machine A axis rotates backwards 354 degrees between these two lines, effectively destroying the work it has already done before, it does this multiple times throughout the gcode, rotating forwards and backwards, resulting in a straight cylinder.

This is another example:
G1 Z3.5367 A-7.0000
G1 Z3.5282 A-6.0000
G1 Z3.5000 A-720.0
G1 X3.1680 F1100
G1 Z3.5282 A-714.0 F1000
G1 Z3.5367 A-713.0
G1 Z3.5570 A-711.0

This time it rotates backwards 714 degrees.
Any idea why this might be?

clearly that should not be happening. in a lathe op, the A axis should progress continuously. my test case does not show this, so please send me your workspace (right click export to produce a .kmz file) via DM or email [ sa at grid dot space ]

I found an un-merged fix in 4.x that addresses this. Will back-port to 3.9 and push today. Thanks for the heads up.

1 Like

if you want to test before the push, use the dev instance at

it’ll load a bit slower because it’s not optimized for production

1 Like

Thanks. I am ten minutes into the lathe operation and it is looking good.

1 Like

It worked perfectly, this was the result:

1 Like

that looks awesome. glad it worked out. production will be updated in a couple of hours.

1 Like