Origin at 0,0 of cut area, not model(s)

Many versions ago you used to be able to set the origin at the center of the CNCs possible cutting area. Now it seems to always do 0,0 relative to the model(s) you have imported. Am I missing something or was this option removed? If removed, can it be added back?

only by setting the stock to the size of the workspace

Can I move the models independent of the stock, or lock the stock to always be in the middle? It seems to always want to put the models in the middle of the stock basically doing the exact same thing as if I don’t have a stock at all.

Being able to put 0,0 in the middle of the cutting area no matter what was incredibly helpful for my CNC and saving on material. Any chance that can be re-added?