Not cutting through all of Z despite correct sizes

Hi Stewart,
I usually have no issues cutting my simple jobs on my homemade CNC, but this one is strange: It finished the job 2-3mm before the bottom of Z. And that once I have activated “First Z Max”.
When I run the preview and count the passes multiplied by 2mm step-down, it confirms my problem.
And now, even when I un-check the First Z Max, I can’t get it to do it right either!? I cleared the cache…

I guess I must be missing something?!?
I attached the NC. STL is not accepted.

Thanks a lot and thanks for all your work, it is greatly appreciated by all of us.
Take care,
Martin (46.8 KB)

Can you right-click export the workspace and DM or drop the .kmz file here?

Hi Steward, sure, but not sure what DM is…!? In any case, here is the .kmz file.
Oh, and once you are at it, do you see why I can’t drill a simple hole, no matter what size of bit I create?

Cheers and thanks.
workspace.kmz (195.7 KB)

Hi Stewart, not sure if my last message arrived, since usually you reply in no time…!?

Hi @Martin_Svejda

The zThru option is ignored by roughing, but honored by outline. This needs better documentation. So adding an outline op after roughing will complete the cutout. Workspace attached


z thru outline.kmz (403.1 KB)

PS - I’ve been traveling and mostly offline for the last few weeks