New 2.0 build-- hiccup in the xy motion

Trying to figure out what’s going wrong. Seem to have a mechanical drag somewhere in my xy motion. Double-checked idlers today, with two washers on top of each idler and the lock nut inverted on the bottom so they should spin freely relative to each other.

If I move just the y-axis 200mm I can see the head jump over 1-3mm in x as it travels. Bringing y back the x jumps back along the way. Tried adding and removing tension on the belts, freeing the idlers as mentioned above, and adjusting the lean on the steppers to try and keep the belts off the top pulley flange (though the mounts are flexing more than I’d like still).

Upped the driver current to 1000mA and tried playing with acceleration, but I’m pretty sure I’m not skipping steps. Also tried a couple different slicers in case I had a parameter wrong somewhere. Photo is a first layer of a test print I’ve been trying, where the segment sides should all be in line and the tabs should be centered on each other. When it jumps it seems to be about 1mm, and jumps back as the head traverses onward-- not a layer shift thing like you’d expect with missed steps.

Anyone else encounter this mechanical hiccup in their builds?


have you checked the stepper connections (wiring) to make sure they’re not loose on one end or the other?

I did. The x movement occurs in the same place along the y travel, and then reverses on the travel back. An electrical issue would skip steps that would increase offset throughout z layers, which I’m not seeing. Also thought it might have been a TMC driver issue, but tried swapping those to no change. Large travels start and end at the same spot, both linearly and at an angle.

Also have gone through marlin configs a lot, and tried a couple different slicers and gcode/usb print apps with the same result. That’s why I’m thinking it has to be a mechanical issue.

One thing I didn’t do was measure the belt lengths when installing. Any idea how critical that they’re the same length? This is my first corexy and I didn’t think having the same length belts was important, but I may be wrong on that.

Just did some reading online and I’m wondering if my smooth idler pulleys are the issue? The toothed side of the belt is riding on the smooth idler surface on either side of the x gantry and at the front posts. Did you use toothed idlers or smooth?

I use smooth idlers on all my printers. The belt should be trimmed after the appropriate tension is set. I think this design, like many others, uses zip ties to hold the belt end against itself (friction and tooth to tooth) to prevent slippage.

Yep, got the belts mounted and in line. Trimmed the ends to about 1/2 inch and zip tied, so they’re good.

I’ve also used smooth pulleys on my traditional cartesian builds. Just not sure what else could cause the axes to jump back and forth a mm or so during travels. With belts off everything is smooth on the rails. Can even see the print head wobble back and forth in x when I move the gantry back and forth on y by hand with no power. It’s weird.

None of that makes sense. Can you post a video?

Just took a couple videos and posted to youtube. First one shows moves under power-- y traverse followed by the start of a test print:

Second video is without power, showing the gantry moving in x when just pushing it back and forth in y:

On a hunch, I also tried unplugging x and y steppers at the motor to make sure they’re not coupled electrically, and the the x stutters remained the same when pushing the gantry. So not an electrical issue at all-- has to be mechanical.


I’ve never seen anything like that. And I’ve build more than two dozen of these. Are the jogs consistent? If you do the same print twice, are the errors repeatable and in the same spots?

I’ve not seen this with cartesian printers either, though this is my first corexy. Jogs are consistent, and prints are too. Have not measured to the mm, but eyeballing they seem to have the same issues at the same places.

Will try the different idlers today in case there’s something wrong with the first set. After that I’ll grind down my flat washers-- they’re a little wider than the bearings on the idlers. That’s why I used two washers on top of and between each of the idlers and kept the nut a little loose, so they wouldn’t drag.

Beyond that may need to try different belt stock. Just using generic amazon stuff right now, but a good gates belt may be more consistent.

if you unplug the XY steppers and move the belts (not head) by hand, do you get any unusual movement?

It was shifting in x a bit if I moved the gantry by hand with motors unplugged. Moving each belt in turn was a little better, but still would transfer motion to the other belt a little.

Idlers got here today and the Gates belt is due tomorrow so will put back together tomorrow evening. The cheapo import belt I had used did have some stickiness on the edge in places due to the packing tape that might have engaged the idler. Also unsure of the quality of the width-- the gates belt should be more consistent.

What washers do you use? I just had some flat steel ones that came with my M5 hardware assortment. Thinking nylon washers might be better as the idler center hub is really thin.

I’ve used metal and nylon washers and both work equally well

It’s working!

Upgraded to a Gates belt (filastruder sells in custom lengths-- pricey but much better quality). Also running toothed idlers where inside of belt rides on the hub.

But I think the core issue was that the set screws on one motor drive pulley were not tight :roll_eyes: That let one axis have some slop as it shifted across the flat side of the pulley whenever the carriage moved.

Really appreciate your patience and thanks for a terrific printer design!!


that actually makes sense. noted for future reference!