Line selection in Trace isn't working properly in 3.8 and 3.9

Hi, I’m trying to use the trace function in the bottom of a V-groove, but can’t select the line directly at the bottom of the groove in Versions 3.8 and 3.9. I can select and generate a path in Version 3.7.

I’ve attached a simple example to demonstrate the problem.

V-GrooveTrace.kmz (142.4 KB)

Many thanks in advance!

Thanks for the test workspace. It looks like I left some code commented out while testing. I’ve got a patch for 3.8 / 3.9 that I will put into production later today that reverses this.


Brilliant, thank you very much!

Having a similar problem on 3.8 and 3.9.D8. Several circular edges on this part are not selectable in these versions, but can be selected in 3.7.

I can’t upload my workspace (new user) but I’ll email it if needed.

Split post because I can only upload one picture per post:

Perhaps related, switching to Hide mode shows only some of the part’s edges – the missing ones are the same ones I’m unable to select in 3.8/3.9:

Do you mind sharing this part or workspace with me? You might be able to upload workspaces now

Happy to! Still no love on uploads, so I sent email to sa at grid dot space…

Got the email. Thanks for that. And easy to repro, so I should have this fixed sometime tomorrow. Not sure if I’ll be able to push to production since I’ll be traveling.

I’ve got a fix checked in. Will push to production after 10PM EST today.

workspace tool shelf.kmz (769.4 KB)
I’m having problems selecting edges in Trace mode. I saw the post that said you fixed it, but I still can’t select the same lines that i could select in 3.7. Like on the lower edges of the bevels of the attached model. And the the inside circle on the beveled holes. If I revert to 3.7 all these edges are selectable.

@Carl_Olsen thanks for the workspace. I have a fix that I’ll push to 3.9 in production in the next couple of hours.