Kiri Moto only loading screen

Hy community. I’m running kiri on debian 11 with the command gs-app-server --port 8181 because 8080 is already in use. but when I open the browser I only get to this screen:

Testet on chrome and brave browser.

Are there any errors on the Javascript console in the browser?

The debian server is running on Proxmox as VM. I testet kiri on a lxc container and its working fine. but I want to run it on my octoprint vm server.

it looks like two things failed to load: wasm for the Manifold library and the language module. I have not tested Brave on linux, so perhaps it is doing something out of spec. is the browser on a different OS? or are you just testing the server running on different hosts?

I open kiri Website with Windows 11 browser Brave or Chrome. Always had same result. My local server have Proxmox with a running NAS (lxc container with debian 11) and a VirtualMachine for Octoprint(debian 11). Testet kiri on the NAS system and i had no problems connecting with brave. Then I decided to run kiri directly on my octoprint VM with the given result.

I also testet kiri on the VM with standard port 8080. Same result

In all these cases, the browsers are on the same machine that work with, but not when using the OctoPrint VM as the server instead?

Hi, I was trying to run kiri on my local server, and I ran into these same errors. Here’s how I fixed it:

  • The “post install” script never ran, so I was missing src/ext/manifold.js and src/wasm/manifold.wasm. Manually running bin/nmp-post fixed the first issue. Any reason these files aren’t included in the repo, and need to be downloaded separately?

  • Try running not in debug mode. When I did, I got a message that the cache had been updated, and this fixed the ‘kiri.lang’ issue. Note that once the cache updated, I can run in debug mode with no issue.

I haven’t used it for anything yet, but at least the site is loading for me and seems to be working fine. Server is running debian and the client is Win7 with Firefox FWIW.

Unclear why post-install wouldn’t run. Those files are not included because they are large binaries. Also, I have not switched over the the official Manifold npm package yet. I’m still using my code from the pull-request that led to the new API.