"Inside only" goes outside by the tool width

I am trying to machine what is effectively a pocket where I want KM to surface the face of the part without going outside the stock. However, as seen in the screenshot below, even with “inside only” selected the roughing toolpath is going right to the edge of the stock, such that the tool is actually cutting the radius of the tool past the edge of the stock. Is there any way to keep the cutting face of the tool inside the stock?

Also problematic, those cuts that go past the “stock” do so at the full depth of the cut, in this case over 30 mm. This obviously won’t make most CNCs very happy! Here is an example of the suspect code:


All prior toolpaths (the concentric clearing cuts) end at Y 34.2185 but these deep cuts end at Y 36.6

I think you’re referring to this transition between the roughing operation and the contour? roughing by definition leaves some material and a steep angle will enhance that.

“inside only” as defined in KM prevents paths (center of tool) from extending beyond the part, but not the tool itself. clipping paths that keep the tool fully inside the stock obviously has other implications, such as leaving uncut parts of the geometry.

However, there are newer ops like pocket that provide other features. We can use pocket to both “rough” and “finish”. And it offers offset options to keep paths inside the selected “pocket” or face.

I’ll email you the updated workspace for your inspection.

1 Like

Thanks! Pocket looks like what I need. I didn’t think of that because the object doesn’t look like it has pockets.

Regarding your comment “I think you’re referring to this transition between the roughing operation and the contour? roughing by definition leaves some material and a steep angle will enhance that” – no, actually, it is the roughing that is the issue. The contour did exactly what I expected (given the tool path extends to the edge of the stock).

If you look at the top view of the tool path from my image above where I stopped it is right at the problem area. You can see the previous step down is the small triangular paths in the bottom right corner. You can see those triangular tool paths are all a tool radius inside the stock. However, the first cut of the next stepdown goes all the way to the stock edge, which at that point is about 30 mm deep in the stock. That causes a cut much taller than the flute length, which would cause serious problems.

Here is a detail of what I am talking about:
KM Toolpath Screenshot 2_20240701_192112

The left arrow shows the tool extending a radius over the stock, but the right arrow shows where previous cuts were all a tool radius inside the stock.

Let me know if that explanation makes sense. Since there is a better solution with the pocket tool this isn’t a problem for me, but if you can figure out a way to fix it at some point it might help someone else.

this is an artifact of the stock clip to setting you have enabled. it changes the roughing path. try disabling and enabling it and notice the difference in the path at the edges. make sure you disable the contour op, too so it’s easier to see.

1 Like

Ah, yeah, that setting seems to affect part of the roughing tool path but not all of it. Thanks for the clarification.

Another question: I am trying to understand the units of the “Expand” setting in the pocket operation. What I am seeing is that the toolpath stays twice the “Expand” distance, in workspace units, away from the edges. So if I set Expand to -1.6 the tool actually stays 3.2 units (mm in my case) from the edge of the pocket wall. I was expecting “Expand” to be in workspace units but let me know if I am misinterpreting how that was intended.


The code indicates this is in workspace units and this test seems to agree.

1 Like

Very odd. I created a similar view with my part. There are some projection variances, given the tool path is not in the same plane as the workspace grid, but the bottom right corner, where the arrow is, is very close to the grid in the Z plane, and when I set expand to -5 you can see that the toolpath is actually 2 grid units (10 mm) away from the edge of the part. I see your tool is metric, mine is imperial, but since it seems to be exactly half that doesn’t seem like it matters. I can send another workspace export if it would help.

Thanks for looking into this!

the contour option is interfering with the expand field in unexpected ways. it seems to be doubling it. looks like a bug. will investigate further.

1 Like

Thanks! I have a workaround so no rush on a fix.

got a fix going in for the next release

1 Like