Inner walls disconnected

The title of this topic is probably not chosen too well, but I think the following screenshot can illustrate my issues. I wanted to print battery boxes ( in Kiri:Moto.
They have an inner grid that serves as compartments for the batteries.
If I slice the model in Kiri, I cannot get the walls of that grid to stay connected.
In Cura, the result seems different - here, the grid is connected.
For larger batteries, the inner walls get bigger and if they are not connected, that grid becomes a bit flimsy. Is there a way in Kiri to change how that grid is created?

See a screenshot of the model render, the kiri slice and the cura slice.

disable the thin wall setting and see what happens

Ah, that did it! Thank you.
What is the primary use case of the “thin walls” option?

internally there are three different imperfect thin wall detection algorithms. I haven’t found a good UI treatment to expose them yet. but the goal is to provide solid walls when they are not a clean multiple of the nozzle width or would otherwise leave small / weak gaps.

Thanks for the explanation.
The print was perfect after disabling “thin walls”, btw.

1 Like