GCode Export Missing Spindle Control

I’m trying to get my first CNC run going using Kiri:Moto. I think I got all of the settings good to go, but when I actually go to run it, the spindle never turns on. Is there some setting I’m missing to include the M3 command in gcode?

1 Like

Hi @AndyG and welcome. You need to set a max spindle speed in your device setup to enable spindle input settings for each milling process. Since all default devices are read-only, start by cloning a device with the “+” button. Then set the max spindle to something above 0.

Once you’ve done that, you can set a spindle speed like this:

Then the generated GCode will include M3 commands:

Screen Shot 2020-07-30 at 5.16.51 PM

Obviously this GCode was generated when I had the spindle set to 1000, not 4000 as pictured :slight_smile:

Alternatively, you could hard-code the M3 command in the GCode header, which is also in device setup.

2 Likes