"Extra" holes drilled when Marking

Marking (aka Spot Drilling) is a great feature, pretty much mandatory for my setup in materials like stainless.

In this case, KM finds a few extra holes to spot drill. Interestingly, the extra holes are also off center.

This is an OnShape model exported to STL with the default options, then imported into KM on grid.space. (I did this to isolate a different problem.) In the OnShape integrated version the problem does not occur, although it looks like the tessellation quality is also different between the two so that might be the real issue.

extra_drills.kmz (385.8 KB)

Do you mind testing older versions of KM to see if this is a recent bug? I’m on a flight and testing is difficult. Thanks for the workspace. I will debug when I can.

I’ve found something puzzling … if you set the slicer “detail” to anything other than 50 in preferences, these artifacts go away. will dig deeper, but at least there is a workaround.

Reproduced on 3.5 (on grid.space). Confirmed your workaround on both 3.5 or 3.8.

Not sure if this is related, but here’s the mesh on the part in the grid.space window (with the problem):

This was the default quality from OnShape export for this part in inches.

(My mill is in inches so my KM workspace is in inches, but importing a mm part doesn’t scale down so I exported from OnShape in inches.)

The same part in the OnShape window has a looser mesh:

found and fixed the bug which was in a base geometry class. the fix will go out with the next update.

thanks for the report and test case