Cut larger than file

Evening! My first post, just found KM a few days ago. I designed a small 57mm cam shape in Fusion, sliced with Cura and it printed exactly. I just built myself a cnc router and use linuxcnc. Everything is set to mm. Using KM and this cam file it wants to cut out about 400mm long… All three axis are exaggerated. I checked the scaling and all three are set to 1. I would really appreciate any thoughts.

Hi David. Have you run axis calibrations to ensure the steps match the gcode? What is the sender/hardware that drives the router? Does the gcode set inches or millimeters and is KM set up to generate inches or millimeters? If there is a mismatch in the configuration, it will exaggerate (scale) your output.

Morning Stewart, I am fairly new to this. I have everything I could find set to mm. Despite this linuxcnc seems to think I am running a 0.125 bit. That would have come from KM. That is not the 6mm bit I thought I measured in. I will try running axis calibration. My file shows 76mm long yet it is actually moving about 76cm.
I may have more than one configuration wrong!

Gcode does not indicate bit size, only paths. So if linuxcnc is showing or rending something else, it’s a linuxcnc setting and not something KM is in control of.

Does your device gcode header include G21?

If you create a simple gcode file by hand that looks something like:

G0 X5

Running that should result in the X axis jogging 5mm. If it doesn’t, you have a firmware configuration problem.

I found a tools chart in linuxcnc, it seems to be using that set. The tool existing there are all imperial. Once I figure out what all the columns are for I will alter. Inserting actual gcode is beyond me at this point. I may need to find some other driver program. see what happens!

you need to manually configure tools in KM and linuxcnc to match. make sure the tool #s are the same.

Hi Stewart, I have the tool issue sorted. If you use linuxcnc could you screen capture from you step configuration wizard the x or y screen? I am convinced I have something wrong in there.
Cannot figure out what though, much appreciated.
Or anyone that uses linuxcnc

I don’t use linuxcnc. Do you know what firmware your mill is running?

Evening Stewart, I don’t believe I have firmware. I have discovered that within linuxcnc, in the step configuration wizard when I test an axis that should travel 15mm it actually travels about 120mm.

your controller most certainly is running some firmware. was this built from a kit? can you post a link?

1 Like

Stewart, thank you for all the help. I got out a calculator moved some dip switches and pulse rates. Everything cuts properly. Have to work on my KM skills now.

1 Like