Contouring not removing enough mat'l

I think this might have been hidden by the bug I submitted on github the other day, which was causing the side of my part to be trimmed off during roughing. (And which you fixed, and released, in record time!!) It turns out that now, contouring leaves extra material in that same area.

Three screenshots, each with pointers to the problem area.

First the model, showing what the edge should look like:

Then, the result of slicing, from exactly the same angle, showing a hint of the problem:

Finally, a closeup of the end result of animation. You can see the extra lip left behind – arrows point to the mostly hidden edge of the blue model, and to the finished result… An actual carve shows the extra lip as well.

I’ll email my workspace. Thanks!

those lines represent the center-line of the endmill’s path, and so must have a flat spot like that for the mill type selected. these paths are truncated because the “inside only” option was checked in your contour op which limits the path to the interior of the part boundary. when I disable that, I get:

notice the flat area continues into a curve. another angle:

and the completed animation shows:

Thanks! I’ve tried it, and see what you mean, and yes, that will fix my problem.

But I guess I don’t quite understand what “inside only” is for, if it only controls the cutting head’s centerline. I’d get it, if it controlled the outside edge of the cutter. But by bringing the centerline to the edge of the part, it’s already cutting outside the part’s bounding profile, and potentially beyond the edge of the stock as well (I think, right?). So when would I want “Inside only”?

a) it’s somewhat of a legacy feature carried forward
b) for a class of parts with exterior walls (like those of a castle), this is useful

I can imagine how it would be useful, except that for contouring the bottom of a hole (as I think you’re describing) I’d have thought it would limit its movement based on the outside edge of the cutter, not the centerline.