Contour seems to cut through Tabs...?

hi, I am trying out doublesided carving for the first time using your software.
I seem to be missing something, but I cant solve the problem.

While the rough cut does not cut through the tabs, the contour cut appears to do so from what the preview shows me. It is likely something Im missing. What am I doing wrong here?
Thanks in advance for your help.

that would be a bug. investigating…

@bongo_matteo thanks for the workspace. I found the issue and it’s an easy fix. I will push an update in the next hour or two that resolves this. it was related to having tabs above the floor of the workspace.

Thanks for your help!
Is there a way to use the flip operation to also rotate only 90 degrees as well as 180?
I would like to try 4 sided carving using this method

glad you asked. this is something I plan to add as part of 4th axis work (discrete and progressive rotation control). it’s a little tricky to shoehorn into the existing flip operation.

@bongo_matteo this is fixed in production. please let me know if it is or isn’t working for you.

Hi and thanks for your help!
Im experiencing problems still, just different… The contour passes are exhibiting errors. I didnt notice them in KiriMoto, but IGS Platform showed them starkly once I opened the gcode there.

Also, for the 1st time I was unable to apply carve passes in isolation - in other words, if I set up a roughing pass, exported the file, then deleted the roughing pass & created a contour pass for the same side, in order to have seperate gcode files for each (due to my inexperience with gcode). Since the contour pass would not render properly alone, I noticed the contour pass appeared to work provided the roughing pass was still present in the operation chain; so I output both to gcode and seperated them manually in notepad++ to produce 2 gcode files. The contour files has errors around deep pocket areas displayed in yellow in UGS.
Here is the workspace file:

thanks for the workspace. I am able to replicate your problem. hopefully it’s a quick fix.

tip for separate exports. you can ctrl+click an operation to enable/disable it. red is disabled. that way you don’t have to delete them.

Screen Shot 2021-12-30 at 12.12.42 PM


I have a workaround while work on a I fix this: enable true shadow under the expert menu. it’s computationally expensive, but does work around the issue.

I have a fix that I will push out later today

Thanks so much!
And for the cntrl click tip!
The more I use Kiri:Moto, the more I love it!

1 Like