CNC Roughing Cuts Through Piece

I’m creating a CNC toolpath. When I use Contour, the result is correct. But when I use Roughing, the tool cuts through the part.

I simulated kiri:moto’s output gcode using CAMotics; I attached screenshots of the results. I suspect that the incorrect cuts are caused by G0 movement where the tool ignores my “Z Clearance” setting.

I tried uploading the workspace’s kmz file, but it exceeded the file size (it’s 6.5 MB).

@danny_evans thanks for the report. can you share it with google drive, drop box, or similar? if you don’t want it to be public, hop on the Discord server and DM the file or link to me.

Sure! Here’s a link to the file on Google Drive:

Thanks. Yes, this is a bug. I realized after opening the workspace that the model that has part hovering over the base. This is likely the cause. Still a bug, though.

Thanks for the fast reply! Earlier today I tried using Blender to extrude the overhanging sections to the base. Blender wasn’t cooperative, but I’m sure there’s an easy way hidden somewhere in the software. I’ll keep looking; that seems like my best way to solve this in the short term.

I hit the same issue while trying to follow a bowl video tutorial.

When milling bottom side of the bowl (model is upside down) at some point roughing pass goes through the model and start milling top face.


I tried different options, but no luck.
Is there a way to fix/work around the issue?

That looks like a shadow calculation error. Can you right-click on the workspace, export it, and email the .kmz file to me [ sa at grid dot space ] or DM it to me on the Discord server. Thanks

Strange, but I no longer see this odd behavior. Version 3.4.4 behaves normally.

Ok. But if you ever get unexpected or buggy behavior, export the workspace for diagnostics.