Chrome, onshape, and KM -- new security?

I started a new project today, did the design in Onshape, and then tried to bring up a KM tab. And nothing happened.

So I went back to a previous project, which already had an associated KM tab, and tried opening that in Onshape. I got the following screen message. When I dismissed the message, indeed KM didn’t function, and simply hung with “Loading…” written on the screen.

I believe I’ve done a full reset of my Chrome settings (while debugging a different issue) since last using KM, so it’s possible that may be a clue.

Any ideas?

Unless this is a new privacy setting … can you bring up the javascript console and look for errors?

I updated Chrome and opened Onshape in an incognito tab to test a total reset and it’s still working for me there, too.

First, I forgot to include the screen shot of the error message I got when opening my old project, with KM already attached to it:

Second, here’s a console log, after that has happened:

Thanks! Hope this helps.

Yep, as the error states, when local storage is blocked, KM may not run. This is common in some Firefox privacy modes. Did you enable something new?

Not to my knowledge. But now, knowing that it’s nothing that you know of having changed, I’ll go looking. Thanks. I’ll let you know what I find.

I forgot to mention that when I attempt to create a KM tab for my new project, the console log reports nothing at all, which seems odd. But perhaps the console is non-functional for Onshape in general?

Okay, it turned out that I’d disabled third party cookies in Chrome, which also disables local storage. Once I added an exception for, then my old project started working fine.

My new project, however, still does nothing and gives no feedback when I hit the ‘+’ in the lower left (to create a tab), and select “Applications” --> “Kiri:Moto”. However, it also does nothing if I do “+” --> “Applications” --> “Go to App Store”. So this seems like an Onshape problem.


1 Like

this lines up with what i’ve seen before. and the other thing does seem like an Onshape problem. perhaps there is a 3rd party issue there, too