Camera disappeared from GridBot controller after update

I recently (earlier today or yesterday) updated the GridBot controller and now my RasPi camera disappeared from the UI.
Have there been any major changes that might cause this?

there have been changes. I will look at the change-log and try to figure out what it is. there is a /tmp/camera.log that may provide insight.

Just saw on Github that there were camera-related changes.
I see a /tmp/gridbot.log but not a camera.log

I just checked in a fix. sorry about that.

No problem, thanks for looking into it so quickly. It looks like I can’t test it right away - the power supply of my raspi and touchscreen just started smelling weird and then stopped working.
It was an Adafruit zero2go Omini that powered Raspi and screen via a 24v line from the printer power supply. Worked great until now. But at least raspi and screen are fine - just confirmed with external power supply.
Have to decide now if I go with the same solution or try something else.

Printer is running again. I still had an adjustable voltage converter that I was able to use to drive the Raspi and screen.
I updated the controller but I still don’t see the camera in the UI.
I double checked if the camera is working with a quick raspistill on the commandline and it worked correctly. I also checked again for a camera.log, but couldn’t find any.

after updating the controller did you restart the pi?

Yes, I did restart the pi.
I just double checked, started the pi, checked for updates (no updates available) and restarted one more time.
The UI starts with the camera icon, but that disappears after a second.

ok, that’s odd. I’m running the same gridbot code on an old pi zero and it’s working. there was a script error in the previous update that’s been fixed. if you want to hop on the Discord server, we can screen share and I can walk you through more debugging.

I found the problem - something must have gone wrong during the update. was empty after the update.

To make sure nothing else weird was happening, I re-cloned and reinstalled grid-bot.
Seems to be fine now. Thanks for offering to help. Not sure why this happened…

Screenshot 2022-02-24 104639

1 Like