CAM Process Reordering in 2.5 - Please Help Test

A very significant update in tonight’s 2.5.D4 release re-imagines how CAM processes are defined and controlled. Please help test. Tons of code was modified and refactored to make this possible. It’s an important step needed to make future features possible.

1 Like


For now i did not see any kind of regression. I will check better in my next projects :slight_smile:

1 Like

It may not surprise you that my first report has to do with inch/mm selection. :wink:
The bubbles that appear over the “Active operation Order” area aren’t converted to imperial.
In addition, my tool identifiers are listed as “1000” for my 1/4" end mill, and for my custom 1/4" round end tool, well, I’ll attach a screenshot.

One more thing: “Tabs” has a dot on it, indicating it’s active, even though I’ve selected no tabs for this project, and the values in that config pane have been reset to defaults of some sort. Perhaps I just don’t know how to “unconfigure” tabs.

And one one more thing: After I’ve sliced or previewed, there’s no longer a way to see what operations I’ve selected, or their order.

And the final thing for this post, really: I realized I had the contour “tolerance” set much too small for doing quick UI testing – my slicing was taking too long. So while slicing was running, I changed the tolerance value, hit ‘A’, and then ‘ESC’ to stop the current operation – this is how I learned to always successfully abort a slicing operation in D4. The operation halted, but I can no longer perform a new slice. I get the following:

So, after I’ve configured an operation, and “Added” it, it seems that I can no longer edit it, is that right? That seems sub-optimal. First, to make a change I have to add a new pass, remove the previous one from the sequence, and then get my sequence back in order. In addition, while making the change, I have to edit my changes in the config pane which may or may not match the current settings. And I can’t readily refer to the current settings to check, because those are only displayed in (very) transient bubbles.

I’m guessing you know about all of these issues already…


yep, all of this is known. I needed to get it working before I could make it better. keeping me on my toes with units is helpful. the tabs report and cancel failure mode are good to know.

if you click the trash can icon under tabs, does it not clear the dot?

No, it does not. It does bring up the “Clear tabs?” confirmation box, but clicking ‘yes’ has no effect on the dot. Of course, there were no tabs to clear.
How I got there: I was configured for 2.4 (with no tabs in use – can’t remember if the dot was present or not, though I did notice the other day that it seemed to always be present), and switched to 2.5 for testing. The dot on “Tabs” turned on when I made that switch.


mind sending me your workspace?

Sent via email. Sent via email.

thanks. interestingly, when I load the settings the first time, the tab dot is there. I see a lot of leftover widget meta data. and when I reload the page, that meta data (including tabs) is properly cleared.

already fixed the tool name and units for tonight’s release.

BTW, regarding the exporting of profiles – I just realized that the reason I can’t find a way to re-import an exported profile is that you probably implemented that under the catchall “Import” function on the other side of the screen. Is that right?

Two problems: a) It’s counter intuitive to have the export and import so widely separated, and b) since I primarily use Onshape, the “import” function is dedicated to Onshape imports (unless there’s a secret way of getting around that restriction).


Reloading the page doesn’t affect my tabs dot. Of course, I didn’t load my config freshly, as you did, so it’s a slightly different use case.

Onshape does change some behaviors. It does take over the import button. However, you can still drag / drop any file onto the workspace to effect an import. Have you used the new right-click context menu?

My desktop doesn’t do drag/drop, so that leaves me with no way to do non-Onshape imports.

I hadn’t used the right-click menu yet. Just tried it. Seems to work. :slight_smile:

I’ll make it so that if you hold down the [shift] key while clicking “import” inside of Onshape, it brings up the normal import window. Would that work?

Certainly. I hope I remember it!

A more invasive fix is to have the Onshape extension inject more UI components. I’ll look into this, but it might not be quick.

Would it be too difficult, when running with Onshape, to leave the KM import function untouched, and add a new “Import from Onshape” command? (Or maybe this is what you’re implying above.)

that’s what i’m implying

1 Like


Usually i don’t strip comments from the gcode because i like to double check some parameters before start milling.

The “ops” value in the header is a JS object instead of a string :slight_smile:

Here a screenshot